Version `GLIBC_2.27' not found error when installation on ubuntu 16.04


#1

I’m using ubuntu 16.04 when i’m installing botpress v14 i facing the following error

aarbor_01@aarbor01-virtual-machine:~/botpress$ ./bp
Error starting botpress
Error: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.27' not found (required by /home/aarbor_01/botpress/bindings/fasttext.node)
    at Object.Module._extensions..node (internal/modules/cjs/loader.js:729:18)
    at Module.load (internal/modules/cjs/loader.js:610:32)
    at tryModuleLoad (internal/modules/cjs/loader.js:549:12)
    at Function.Module._load (internal/modules/cjs/loader.js:541:3)
    at Module.require (internal/modules/cjs/loader.js:648:17)
    at Module.require (pkg/prelude/bootstrap.js:1160:31)
    at Module.module_1.default.require (/snapshot/build-linux/out/bp/sdk/rewire.js:0:0)
    at require (internal/modules/cjs/helpers.js:20:18)
    at Object.<anonymous> (/snapshot/build-linux/out/bp/ml/fasttext.js:0:0)
    at Module._compile (pkg/prelude/bootstrap.js:1255:22)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:711:10)
    at Module.load (internal/modules/cjs/loader.js:610:32)
    at tryModuleLoad (internal/modules/cjs/loader.js:549:12)
    at Function.Module._load (internal/modules/cjs/loader.js:541:3)
    at Module.require (internal/modules/cjs/loader.js:648:17)
    at Module.require (pkg/prelude/bootstrap.js:1160:31)
/lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.27' not found (required by /home/aarbor_01/botpress/bindings/fasttext.node)
---STACK---
Error: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.27' not found (required by /home/aarbor_01/botpress/bindings/fasttext.node)
    at Object.Module._extensions..node (internal/modules/cjs/loader.js:729:18)
    at Module.load (internal/modules/cjs/loader.js:610:32)
    at tryModuleLoad (internal/modules/cjs/loader.js:549:12)
    at Function.Module._load (internal/modules/cjs/loader.js:541:3)
    at Module.require (internal/modules/cjs/loader.js:648:17)
    at Module.require (pkg/prelude/bootstrap.js:1160:31)
    at Module.module_1.default.require (/snapshot/build-linux/out/bp/sdk/rewire.js:0:0)
    at require (internal/modules/cjs/helpers.js:20:18)
    at Object.<anonymous> (/snapshot/build-linux/out/bp/ml/fasttext.js:0:0)
    at Module._compile (pkg/prelude/bootstrap.js:1255:22)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:711:10)
    at Module.load (internal/modules/cjs/loader.js:610:32)
    at tryModuleLoad (internal/modules/cjs/loader.js:549:12)
    at Function.Module._load (internal/modules/cjs/loader.js:541:3)
    at Module.require (internal/modules/cjs/loader.js:648:17)
    at Module.require (pkg/prelude/bootstrap.js:1160:31)

#2

That’s an issue with fasttext node-binding. Please follow issue on github to see when this gets fixed.


#3

You can use the below version in the meantime, its working correctly
https://s3.amazonaws.com/botpress-binaries/botpress-ce-v11_3_0-linux-x64.zip