unable to login. "Invalid Credentials" How to reset


#1

Version 11.0.4 Getting message: unable to login. “Invalid Credentials” . Tried “admin” and “password”. No luck. Tried: Uninstall and Reinstall – no luck. Even after reinstall, it remembers my old password (shown as masked). How do I reset userName and password?


#2

Did you changed the password ? Default is admin/admin


#3

I did change the password. But the next time I tried to sign-in it would not accept the new password. Is there some way to request a password reset?

Thanks.


#4

In 11-th version password gets saved in SQLite db file under data/storage/core.sqlite.

If you are in local environment and there are no important settings there, you could try removing that file to force botpress reinitialize users.


#5

The problem occured in version 10. Since I am new to botpress, I abandon 10 and am learning how to use version 11.

So far, no issues in it failing to recognize my password. Thanks for the hint about where it is stored.
I used http://sqlitebrowser.org/ to open the core.sqlite file. Under auth_users, I can see (and edit) my user-name and password. No need to delete the entire file. Hopefully I will never have to use this but someone might find it useful in the future.

Thanks again for your reply.


#6

I dont think the same trick would work with Postgresql!