Question & Answer Module not working

@alex The question and answer module is hardly working. I launched a small talk bot. Waited for five minutes then started interogating it as below with only one successful enquiry:

The complete console log is as follows:

$ ./bp
17:28:53.646 Launcher ========================================
                                  Botpress Server
                                   Version 11.5.0
                      ========================================
17:28:54.674 Launcher Using 6 modules
                      ⦿ MODULES_ROOT/analytics
                      ⦿ MODULES_ROOT/basic-skills
                      ⦿ MODULES_ROOT/builtin
                      ⦿ MODULES_ROOT/channel-web
                      ⦿ MODULES_ROOT/nlu
                      ⦿ MODULES_ROOT/qna
17:28:55.110 ModuleLoader File 00_create_shortlink.js has been changed manually, skipping...
17:28:55.252 Server Loaded 6 modules
17:28:55.375 CMS Loaded 6 content types
17:28:56.320 HookService Executed "builtin/00_create_shortlink.js" on "after_bot_mount"
17:28:56.479 HookService Executed "builtin/00_create_shortlink.js" on "after_bot_mount"
17:28:56.482 HookService Executed "builtin/00_create_shortlink.js" on "after_bot_mount"
17:28:56.483 Server Started in 1809ms
17:28:56.483 Launcher Botpress is ready at http://localhost:3000/
17:30:04.220 HookService Executed "builtin/00_create_shortlink.js" on "after_bot_mount"
17:30:07.616 HookService Executed "builtin/00_dialog_engine.js" on "after_incoming_middleware"
17:30:35.957 Mod[nlu] Models need to be retrained
17:30:35.957 Mod[nlu] Training intent classifier
17:30:36.089 Mod[nlu] Done training intent classifier
17:30:36.089 Mod[nlu] Training slot tagger
17:30:36.458 Mod[nlu] Done training slot tagger
17:30:37.951 HookService Executed "builtin/00_dialog_engine.js" on "after_incoming_middleware"
17:30:37.952 DialogEngine EVENT RECV
17:30:37.952 DialogEngine END FLOW
17:30:58.820 Mod[nlu] [Native] error extracting duckling entities [Error, connect ETIMEDOUT 34.198.202.18:443]
STACK TRACE
Error: connect ETIMEDOUT 34.198.202.18:443
    at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1158:14)
17:31:01.980 HookService Executed "builtin/00_dialog_engine.js" on "after_incoming_middleware"
17:31:01.981 DialogEngine EVENT RECV
17:31:01.981 DialogEngine END FLOW
17:31:10.992 Mod[nlu] [Native] error extracting duckling entities [Error, getaddrinfo ENOTFOUND duckling.botpress.io duckling.botpress.io:443]
STACK TRACE
Error: getaddrinfo ENOTFOUND duckling.botpress.io duckling.botpress.io:443
    at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:50:26)
17:31:14.406 HookService Executed "builtin/00_dialog_engine.js" on "after_incoming_middleware"
17:31:14.406 DialogEngine EVENT RECV
17:31:14.406 DialogEngine END FLOW
17:31:20.151 Mod[nlu] [Native] error extracting duckling entities [Error, getaddrinfo EAI_AGAIN duckling.botpress.io duckling.botpress.io:443]
STACK TRACE
Error: getaddrinfo EAI_AGAIN duckling.botpress.io duckling.botpress.io:443
    at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:50:26)
17:31:26.454 HookService Executed "builtin/00_dialog_engine.js" on "after_incoming_middleware"
17:31:26.455 DialogEngine EVENT RECV
17:31:26.455 DialogEngine END FLOW
17:31:39.015 HookService Executed "builtin/00_dialog_engine.js" on "after_incoming_middleware"
17:31:39.015 DialogEngine EVENT RECV
17:31:39.015 DialogEngine END FLOW
17:31:45.677 Mod[nlu] [Native] error extracting duckling entities [Error, connect ETIMEDOUT 34.195.156.192:443]
STACK TRACE
Error: connect ETIMEDOUT 34.195.156.192:443
    at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1158:14)
17:31:48.022 Mod[nlu] [Native] error extracting duckling entities [Error, getaddrinfo ENOTFOUND duckling.botpress.io duckling.botpress.io:443]
STACK TRACE
Error: getaddrinfo ENOTFOUND duckling.botpress.io duckling.botpress.io:443
    at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:50:26)
17:31:50.688 HookService Executed "builtin/00_dialog_engine.js" on "after_incoming_middleware"
17:31:50.688 DialogEngine EVENT RECV
17:31:50.688 DialogEngine END FLOW
17:31:58.325 Mod[nlu] [Native] error extracting duckling entities [Error, getaddrinfo EAI_AGAIN duckling.botpress.io duckling.botpress.io:443]
STACK TRACE
Error: getaddrinfo EAI_AGAIN duckling.botpress.io duckling.botpress.io:443
    at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:50:26)
17:31:58.326 Mod[nlu] [Native] error extracting duckling entities [Error, getaddrinfo EAI_AGAIN duckling.botpress.io duckling.botpress.io:443]
STACK TRACE
Error: getaddrinfo EAI_AGAIN duckling.botpress.io duckling.botpress.io:443
    at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:50:26)
17:31:58.329 HookService Executed "builtin/00_dialog_engine.js" on "after_incoming_middleware"
17:32:06.456 HookService Executed "builtin/00_dialog_engine.js" on "after_incoming_middleware"
17:32:06.456 DialogEngine EVENT RECV
17:32:06.457 DialogEngine END FLOW
17:32:25.685 Mod[nlu] [Native] error extracting duckling entities [Error, connect ETIMEDOUT 34.198.202.18:443]
STACK TRACE
Error: connect ETIMEDOUT 34.198.202.18:443
    at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1158:14)
17:32:42.787 HookService Executed "builtin/00_dialog_engine.js" on "after_incoming_middleware"
17:32:42.787 DialogEngine EVENT RECV
17:32:42.788 DialogEngine END FLOW
17:32:51.796 Mod[nlu] [Native] error extracting duckling entities [Error, getaddrinfo ENOTFOUND duckling.botpress.io duckling.botpress.io:443]
STACK TRACE
Error: getaddrinfo ENOTFOUND duckling.botpress.io duckling.botpress.io:443
    at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:50:26)
17:37:45.407 DialogJanitor 🔎 Found inactive sessions: web::yCBbPqV4jFJSgN5RF53ak::11
17:37:45.407 DialogEngine TIMEOUT

Please assist

Hi, seems like you don’t have internet access? Please disable duckling in NLU.config file (global/config/nlu.json).

3 Likes

Thanks a span. My problem exactly

same problem i am facing, i launched a small talk bot. if i type the correct question but the bot not respond. in my botpress console it showing “end flow” “timeout”

Hello all, I have connected to Rasa NLU successfully and i am getting response as well .
I have added few Q&A , when i ask general questions configured in Q&A . it is even calling RASA nlu.
How to skip RASA NLU when i ask questions configured in Q&A.