Problem returned: Emulator display failure v 12.0.0 and v 12.0.2 (but not 12.0.1)

Hi there, I’ve been trying the latest version (for a couple of hours) and everything works good, except now the Emulator just disappeared somehow. I just get this message directly in the browser interface when I try to access it:

Could not display component

An error occurred while loading the component

Minified React error #31; visit https://reactjs.org/docs/error-decoder.html?invariant=31&args[]=object%20with%20keys%20{type%2C%20title%2C%20url}&args[]= for the full message or use the non-minified dev environment for full errors and additional helpful warnings.

Developer? click hereto see why this might happen

There are no extra clues via the CLI and it seems to be working well other than that. First time I restarted I could open the chat via the admin bot workspace and ask a couple of questions and then it failed and now this doesn’t work either and I get the same message there.

Any tips? :slight_smile:

Hi @mipodi, which bot template have you used ? Can you try out 12.0.1 also ? We fixed a couple of bugs with that release.

Can you give me the steps required to reproduce it ? It looks like an invalid payload was sent to the web chat.

Hi @allardy, I tried out 12.0.1 now and it works again. Thanks! :smiley:

(I use an empty template for one bot that I’ve filled myself and a welcome bot built on welcome template).

Hi again!

This problem has returned with the latest version.

I downloaded 12.0.2
Replaced data folder with my own data folder
Ran it with ./bp --auto-migrate
Opened web interface in my browser
Tried to click on “Open chat” on my bot via the Workspace and I got the above failure message
Tried to open the emulator via the conversation tree and got the same
However, the welcome bot works as expected
I tried to start it with ./bp and it made no difference

I also double checked 12.0.1 again and the emulator works there. I made no changes between 12.0.1 and 12.0.2. This is what the console says:

I don’t have a custom css style sheet or anything like that.

here:

55

What do you see in the console ? The error that bothers me is the last one (connection refused on socket.io). that means that the backend is unreachable.

You have tried the emulator on the studio, and the embedded-webchat with the same result ?
How did you see that welcome bot was working?

Thanks for your reply! Now I tried doing it again. I opened up the web interface and that last error doesn’t show in the console. Only “failed to load resources” and the “invariant violation minified react” error. I tried the emulator on the studio and the embedded-webchat with the same result. I saw the welcome bot was working because it opened up a new tab with the webchat and I could talk to the welcome bot, same with the emulator. And it one threw no errors in the console.

I waited about ten minutes and then I tried opening again and now I just get this view:

It looks like this in the console:

here is the CLI

if I refresh the page I just get the same error but with a new error progress bar in the top right corner rolling backwards and then disappearing when reaching the finish point. I tried once more to quit the process in the CLI and run again with ./bp but no change.

Maybe I should start over completely, build on a clean install with a bot template as foundation? :slight_smile:

Try to rename your data/ folder to something else temporarily, and restart Botpress. It will re-create the folder from scratch and run as a new installation. Then we will know if the issue is with the data/config or with the executable

Ok, now I renamed the folder, restarted and it ran as a new installation.
I registered an account and created a new bot with welcome bot template.
I pressed the embedded webchat and it works and throws no errors in the console.
I opened the emulator from the flow view, it works but in the console I get “Failed to load resource: the server responded with a status of 404 (Not Found) custom-theme.css:1”

In the CLI in the terminal on my computer there are no errors.
Then I waited 20 mins and clicked to get back to admin panel
Then I got this error in the console:


I clicked on open chat (embedded-webchat) and on the emulator on the studio and both works. Only the GET error follows me around and the number after localhost changes to 13.

So I guess it’s with the data/config then? :smiley:

Hello, for reference (maybe it is related/can provide clues): I deployed this new installation to heroku and when I click on the emulator button, the emulator window does not appear. In the console nothing happens. I thought I might bring it up because this happened with the 12.0.1 which I also deployed to Heroku and that version the emulator worked locally as well.

Though, I get error messages when I go from the workspace to the studio:

I get sort of the same ones when I use this embedded web chat link:
https://desolate-depths-16113.herokuapp.com/lite/testbot/?m=channel-web&v=Fullscreen&options={"hideWidget"%3Atrue%2C"config"%3A{"enableReset"%3Atrue%2C"enableTranscriptDownload"%3Atrue}}

I can make another forum thread if these are unrelated.

Hello, it’s normal for the custom css error. If you want to change the css, you just need to create the file and it will apply the styling.

WHen you get 500 errors on the chrome console, also please provide the errors you have in the botpress console. I’ll try to make the same on heroku to see if there is another issue

Hi, ok. I managed to get a version up from a clean installation with no bot in it up on Heroku. And then it worked as expected. I tried to export and import my bot but just got massive amounts of errors. I added some conversation bits directly in the studio there, saved and tried it out and then they just disappeared after half an hour, as if Postgres didn’t work somehow (but I had it installed).

I have to take a break from this, I’ve been working with Botpress for six months now and there are just too many obstacles. I appreciate you making this bot framework though.