Package "module-builder" refers to a non-existing file when running yarn build

Hi, I was trying to build a custom module for botpress. I was following this: https://github.com/botpress/botpress/tree/master/examples when I run yarn && yarn build in module-templates/basic-module directory, I’m getting an error message: error Package "module-builder" refers to a non-existing file '"/home/cedex10/Downloads/botpress-master/examples/build/module-builder"'.. How could I solve this?

Hey Cedex Technologies, welcome aboard.
Documentation isn’t up to date about creating a new module.
You might want to look into : Creating a new module
tldr, you will need to clone the botpress repo locally, run yarn build, make a coffee, then point the module-builder dependency of your new module to the newly built module-builder inside botpress.

Your compiled module-builder should look similar to this : https://git.fixrs.ca/dismoi-public/module-builder , but up to date.
You might also add the dev dependencies of module-builder into the your own dev dependencies.
https://git.fixrs.ca/dismoi-public/module-builder/blob/master/package.json#L48
Since they are required to build your module.

Thanks. It worked. Now, I’m trying to build one of the example modules ( basic - https://github.com/botpress/botpress/tree/master/examples/module-templates/basic-module ) available the repository. I have modified devDependencies for module-builder as you have mentioned and it is now continue building until I get another error: TS2307: Cannot find module ‘botpress/ui’. How to fix this?