Images not appearing in Card & Carousels


#1

i am using 10.x and ngrok when running https://2d4…6.ngrok.io
in local computer images are appear but when above link open in another computer images are not shown
why this happning ?


#2

@KristlyDsena Are you using 10.x or 11.x ? You talked about 11.x in your last post, and there are major differences between these two versions. If you use 11.x, you need to set the config httpServer.externalUrl in botpress.config.json so the external URL is known to the server


#3

@allardy sorry to confusing you, but i have made bots in both version lets take 11.x and how i use httpServer.externalUrl can you define it with example


#4

@KristlyDsena I’m not sure about the ngrok image, but the builtin image content type is meant to display an image uploaded to your bot. When you create an image using the content manager, it should be fully supported by Botpress.

Here, it would be available locally. But if you access your bot from an external source, you would need to specify the external url, so botpress knows where it is located.

If you want to send an image that isn’t hosted by your bot, you would need to create a custom content type that would link to the desired url.


#5

ok,thank you i have another question which is silly but answer it
like in documentation,
http://localhost:3000/s/<<Bot ID>>
as i said i use ngrok
https://2d4…6.ngrok.io
now bots are in project/data/bots/bot1...bot2...etc
so how to open fullscreen bot bot1 with ngrok url plus i have error in embedding bot in own website .

58%20AM


#6

@KristlyDsena There is an example on how to embed the webchat out of the box. If your bot is at https://2d4…6.ngrok.io, then you can open the url https://2d4…6.ngrok.io/assets/modules/channel-web/examples/embedded-webchat.html.

This example will work if you create a bot named welcome-bot. Here is the content of that file:

ngr

So basically you need to:

  • Edit botpress.config.json and set the variable httpServer.externalUrl to https://2d4…6.ngrok.io
  • Edit the host and bot ID in the embedded-webchat.html file

That should do the trick


#7

it worked. thanks sir but i have another problem i want auto start means flow i created http://localhost:3000/studio/demo/flows/main start node will run whenever bot load in-short what happens now when user give any input then flow start but i want flow start as soon as bot loads
is this possible?
i refer code from this topic
Proactive actions in version 11.3
47%20PM


#8

@KristlyDsena If I correctly understand, you want to greet the user as soon as the webchat is loaded?

If that is so, this can be easily done. When the webchat is loaded, the user automatically sends a visit event to your bot. This event is discarded by a hook, but you can change this behavior.

Edit hooks/after_incoming_middleware/00_dialog_engine.js and remove visit from the messageTypesToDiscard array.

There is just a little thing that needs to be added, here’s an example:

const messageTypesToDiscard = ['session_reset', 'typing'];

if (messageTypesToDiscard.includes(event.type)) {
  event.setFlag(bp.IO.WellKnownFlags.SKIP_DIALOG_ENGINE, true);
}

if(event.type === 'visit'){
  event.nlu = { intent: {} }
}

Then, the bot will treat the visit event as if the user just spoke to him, so he’ll answer back


#9

thanks @allardy but m not able to see fullscreen bot using url created by ngrok ,
https://376f3750.ngrok.io/s/demo it automatically goes to http://localhost:3000/lite/saligram-demo/?m=channel-web&v=fullscreen&options={"hideWidget"%3Atrue%2C"config"%3A{"botConvoTitle"%3A"Bot%20Emulator"%2C"enableReset"%3Atrue%2C"enableTranscriptDownload"%3Atrue}}
plus i want to change ui of fullscreen bot


#10

just like 11.5.1 also in 11.6.1 Reset the conversation not working properly.


#11

@KristlyDsena We’re aware of the issue with the reset conversation, but for now, you can create a new one to bypass it.

The /s/demo url is created from the value of httpServer.externalUrl in the configuration (or the EXTERNAL_URL environment variable). So make sure to change the configuration, and your short url should work.

Example on how to style the webchat: https://github.com/botpress/botpress/blob/master/modules/channel-web/assets/examples/styled-webchat.html

Example on how to add custom components on the webchat or change the composer: https://github.com/botpress/botpress/tree/master/examples/custom-component


#12

variable httpServer.externalUrl is set to this file data/global/botpress.config.json right?
i did everything just like you said but result is same as before

https://376f3750.ngrok.io/s/demo it automatically goes to http://localhost:3000/lite/saligram-demo/?m=channel-web&v=fullscreen&options={“hideWidget”%3Atrue%2C"config"%3A{“botConvoTitle”%3A"Bot%20Emulator"%2C"enableReset"%3Atrue%2C"enableTranscriptDownload"%3Atrue}}
and also bot ui doesn’t effected by my-theme.css

i refer this topic

47%20AM


#13

I may be incorrect but it may be worth a try.

Refer this thread where I was facing similar issue.

@dmk23 helped by stating that sometimes ngrok is slow in serving images. I used serveo instead of ngrok and it worked.

See if this helps


#14

@KristlyDsena Sorry, I should have been more clear. When I talked about httpServer.externalUrl, I meant to add the externalUrl variable to the existing httpServer, like so:

image

Also, the EXTERNAL_URL variable should be used as environment variable, like when you start it up :EXTERNAL_URL=http....&./bp

I’ll update the documentation to make this clearer