Error starting botpress Error: /lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found


#1

I have installed botpress v11 on or Linux server. When I try to run bp I get the following:

Error starting botpress
Error: /lib64/libstdc++.so.6: version CXXABI_1.3.8' not found (required by /app/botpress/bindings/crfsuite.node) at Object.Module._extensions..node (internal/modules/cjs/loader.js:729:18) at Module.load (internal/modules/cjs/loader.js:610:32) at tryModuleLoad (internal/modules/cjs/loader.js:549:12) at Function.Module._load (internal/modules/cjs/loader.js:541:3) at Module.require (internal/modules/cjs/loader.js:648:17) at Module.require (pkg/prelude/bootstrap.js:1160:31) at Module.module_1.default.require (/snapshot/build-linux/out/bp/sdk/rewire.js:0:0) at require (internal/modules/cjs/helpers.js:20:18) at Object.<anonymous> (/snapshot/build-linux/out/bp/ml/crfsuite.js:0:0) at Module._compile (pkg/prelude/bootstrap.js:1255:22) at Object.Module._extensions..js (internal/modules/cjs/loader.js:711:10) at Module.load (internal/modules/cjs/loader.js:610:32) at tryModuleLoad (internal/modules/cjs/loader.js:549:12) at Function.Module._load (internal/modules/cjs/loader.js:541:3) at Module.require (internal/modules/cjs/loader.js:648:17) at Module.require (pkg/prelude/bootstrap.js:1160:31) /lib64/libstdc++.so.6: versionCXXABI_1.3.8’ not found (required by /app/botpress/bindings/crfsuite.node)
—STACK—
Error: /lib64/libstdc++.so.6: version `CXXABI_1.3.8’ not found (required by /app/botpress/bindings/crfsuite.node)
at Object.Module._extensions…node (internal/modules/cjs/loader.js:729:18)
at Module.load (internal/modules/cjs/loader.js:610:32)
at tryModuleLoad (internal/modules/cjs/loader.js:549:12)
at Function.Module._load (internal/modules/cjs/loader.js:541:3)
at Module.require (internal/modules/cjs/loader.js:648:17)
at Module.require (pkg/prelude/bootstrap.js:1160:31)
at Module.module_1.default.require (/snapshot/build-linux/out/bp/sdk/rewire.js:0:0)
at require (internal/modules/cjs/helpers.js:20:18)
at Object. (/snapshot/build-linux/out/bp/ml/crfsuite.js:0:0)
at Module._compile (pkg/prelude/bootstrap.js:1255:22)
at Object.Module._extensions…js (internal/modules/cjs/loader.js:711:10)
at Module.load (internal/modules/cjs/loader.js:610:32)
at tryModuleLoad (internal/modules/cjs/loader.js:549:12)
at Function.Module._load (internal/modules/cjs/loader.js:541:3)
at Module.require (internal/modules/cjs/loader.js:648:17)
at Module.require (pkg/prelude/bootstrap.js:1160:31)

Has anyone had a similar issue? Is there a known resolution?

Thanks!


#2

Hey. I’ve the same problem for several weeks, did you find the solution ?

Kindests regards,
Aubin.


#3

Our solution was to run BotPress in a Docker container. Not ideal but it seems to work.