Could not require NativeExtension "fasttext.node" for "linux ubuntu_16_04"

I’m trying to run bot in linux.
I created bot using 11.4 . I gave yarn and yarn build.It was built successfully,but then i couldn’t start it. i get the error —Could not require NativeExtension “fasttext.node” for OS “linux ubuntu_16_04”. Tried the following paths: [ /home/ies/ies-chatbot/build/native-extensions/linux/default/fasttext.node ]

what should i do ? please kindly provide a solution.

1 Like

Hi, do you have any update on this issue?

One fix is to Update your linux os to 18…04, then start your potpress ./bp

I know the real reason, it “Error: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.27’ not found”, so ensure your libc version with “strings /lib/x86_64-linux-gnu/libc.so.6 | grep GLIBC_”