Botpress and Recast integration


#1

Hello!! I tried botpress and LUIS earlier but it wasn’t working for me so I was forced to use a different platform and I chose Recast. I want to use botpress for its flows and recast for nlu. In my nlu.json, if I change the ‘provider’ to ‘recast’ then I get bunch of errors. I haven’t changed any file other than nlu.json. Any help would be much appreciated.

My nlu.json:
{
“intentsDir”: “./generated/intents”,
“entitiesDir”: “./generated/entities”,
“provider”: “native”,
“debugModeEnabled”: true,
“minimumConfidence”: “0.3”,
“recastToken”: “57e186ca5f8d21777c65b027c193f6ee”,
“recastUserSlug”: “pallavi1994”,
“recastBotSlug”: “ce971a15da13a35586008d858fe70aab”
}


#2

Hi @pallavi0902 Can you provide your errors?


#3

Like I said I get these errors when I change provider to ‘recast’.



#4

Hi @pallavi0902 please replace "provider": "native", -> "provider": "recast",


#5

Hi @pallavi0902

I have made this topic about recast : Botpress-nlu with Recast

ERR Error starting botpress: Converting circular structure to JSON

Is solved when botpress is upgraded (to 10.31 or more)

Be careful of using the developer token and not the request token.


#6

Hello @Delphine !!!

I looked at your topic of botpress-recast integration and it looks very helpful. I’m going to upgrade botpress and then follow with configuration.

Thank you so much!!!


#7

I did replace and that is what the problem is, if i change provider from native to recast, it will throw error. :expressionless:


#8

Please, provide your log and config file


#9

Guys did it work with Recast. i get the below error when I try to run the Default that is created when we do Create Bot in Botpress.
And below i have used developer token.

05:03:00.863 Mod[nlu] [Recast] Syncing Model...
05:03:39.943 Mod[nlu] [Recast] Synced Model
05:04:11.197 HookService Executed "00_dialog_engine.js" on "after_incoming_middleware"
05:04:20.316 HookService Executed "00_dialog_engine.js" on "after_incoming_middleware"
05:04:20.319 DialogEngine Flow started.
05:04:20.350 Actions Running "getUserVariable"
TypeError: Cannot read property 'intent' of undefined
    at Object.<anonymous> (vm.js:3:24)
    at NodeVM.run (c:\Botpress\botpress\node_modules\vm2\lib\main.js:419:27)
    at Promise (c:\Botpress\botpress\out\bp\core\services\action\vm.js:9:37)
    at Promise._execute (c:\Botpress\botpress\modules\channel-web\node_modules\bluebird\js\release\debuggability.js:313:9)
    at Promise._resolveFromExecutor (c:\Botpress\botpress\modules\channel-web\node_modules\bluebird\js\release\promise.js:483:18)
    at new Promise (c:\Botpress\botpress\modules\channel-web\node_modules\bluebird\js\release\promise.js:79:10)
    at VmRunner.runInVm (c:\Botpress\botpress\out\bp\core\services\action\vm.js:7:16)
    at TransitionStrategy.<anonymous> (c:\Botpress\botpress\out\bp\core\services\dialog\instruction\strategy.js:176:33)
    at Generator.next (<anonymous>)
    at c:\Botpress\botpress\out\bp\core\services\dialog\instruction\strategy.js:19:71
05:04:20.489 Transition Condition "true" OK for "ask-name"
05:04:20.510 DialogEngine (main.flow.json)[entry] -> [ask-name]
05:04:20.545 Actions Output "#!builtin_text-z0J9qh"
05:04:22.000 Mod[nlu] Error extracting metadata for incoming text: operation timed out after 2664 ms, 3 tries with error: Request failed with status code 400

Here is my nlu.json

{
  "$schema": "../../../assets/modules/nlu/config.schema.json",
  "intentsDir": "./intents",
  "entitiesDir": "./entities",
  "modelsDir": "./models",
  "provider": "recast",
  "debugModeEnabled": true,
  "minimumConfidence": 0.3,
  "maximumConfidence": 100,
  "rasaEndpoint": "http://localhost:5000",
  "rasaProject": "botpress",
  "luisAppRegion": "westus",
  "maximumRequestsPerHour": 1000,
  "recastToken": "36410125c34cc35ebd04bd25061d725e",
  "recastUserSlug": "newthings4learning",
  "recastBotSlug": "testbotpress"
}

Model seems to be syncing properly as i can see all these intents getting created in Recast @hello @none @forget. But as soon as i send “hi” to bot, it throws the error.

I also observed that models directory is not getting created inside my bot folder in Botpress when i try to connect to Recast or Rasa NLU provider. is this expected ?

I am facing same error when i try to use Rasa NLU.

Any suggestion or help would be highly recommended.


#10

hi guys - i did some more analysis and it seems there might be some problem in sending the POST request using AxiosInstance in the recast.js file.
i have also logged an issue for the same:
Issue with Recast Provider v11.x