Bot Information Page not displaying

Hi!

I am using V12.0.6 .

I have enabled display Bot Information Page as described here:

I have uploaded an image and have filled out the information on the admin.

I have tried the global config and also a per-bot config. Neither seems to have any effect: the bot information page is not displayed.

Other than what is said in the insructions, anythign else to look out for that might possibly be causing the information page NOT to display?

Thanks!

@lampyon-canada Not sure why, but this worked for me. You need to enable both showBotInfoPage and infoPage.enabled property to true, in order to enable bots information page.

Check the bottom section of this How to guide for more information.

Thanks! I checked the How to guide. I have those 2 changes (showBotInfoPage and infoPage.enabled to true) in the bot-specific json and also in the global json, trying both. And still I cannot get the bot info page to display. I have fille dout some of the bot info page data in the admin, but it just will not display. Unfortunately I don’t know where to even begin to find the cause. :frowning:

@lampyon-canada ok let see what we can do here.

Do you see a small information icon on your emulator?
image

Can you share the relative path of the file(s) where you made changes for enabling the bot information page, also the snippet where you made changes?

Are you seeing any error in your botpress source console or browser console (chrome press f12 to view console)

Hi, and thank you! Here are the requested responses:

  • No, there is no information icon in the emulator (or the live webchat window).
    image

  • I enabled the bot information page in the global and then also in the bot specific config file, i.e.:
    botpress\data\global\config\channel-web.json
    and
    botpress\data\bots\test-bot\config\channel-web.json

  • Not sure what “botpress source console” is, but I did check the console (F12) in Chrome on the live page: no errors in console.

I hope this helps. Let me know if there is anythign more I can do to help you help me. :slight_smile: Thanks again!

Can you please share the code snippet that you added in above file? If no other changes are made, then your channel-web.json should match below screenshot.
image

Yes, sorry I forgot to send this. So this is from the global one, the same one you posted:

The bot specific one is identical, the only difference is the $schema path has an extra “…/” there.

I am also thinking whether this might have somethign to do with Docker and updating files already on the Heroku server.

I made these changes to the JSON config files that we discussed above. I then copied these to a deployment folder where my Dockerfile resides. I copied the directory structure, and any files that I changed from the default value so this is what I have in my deployment folder on my local computer:

image

Then I do container login, push and release as per manual. I see that the changes are beign pushed to the Heroku server because for example I enabled the HITL and History modules, and I do see those on the live admin interface. But at the same time I also see an error message for my Messenger channel config file saying I should have a verifyToken value specified - even though that value IS specified in the config file.

So it seems as if some config values were being updated on the server when I deploy, whole others were somehow not. And not sure if the BotInfo values might be havign similar issues, i.e. the settign in my local config JSON files is correct, but for soem reason the live server doesn’t use those values.

I am just unsure how I could check that.

Ok, I have not worked on docker and heroku, but let us isolate this problem of bot information from them. Try the following

  1. Download a fresh botpress binary from the official site.
  2. Run bp
  3. Create a test using an empty bot template and modify it’s config to add a cover image.
  4. Make changes in D:\Temp\botpress-v12_0_7-win-x64\data\global\config\channel-web.json file as shown in your last shared screenshot.
  5. Restart bp and refresh admin page

This should work as I just now followed the same steps on v12.0.7 and I can see my bots information page.

If this works then there is something related to docker/Heroku deployment and maybe @EFF or @allardy from the Botpress team can help.

Thanks!

Yes, if I try this locally, the bot info page is available once I enabled it from the JSON config file.

So then this is a Heroku/Docker issue probably with config files not updating on Heroku as they should?

@lampyon-canada Seems like that, lets wait for the botpress team to comment on this.

1 Like

Meanwhile I have abandoned Docker and Heroku. Instead I installed Botpress on one of our Windows webservers. It works, BUT… the original issue is still there! Namely:

I start the Botpress server on the Windows server. I create a new bot there using the admin interface. I thought that then a new /data/bots/BOTNAME filder would be created for example. But no, nothing there. Also, if I try to edit JSON config files, changes are again not having an effect - goign back toi my original problem.

So at this point I do not understand. If I change a config JSON file and restart the Botpress server, shouldn’t the changes settings take effect?!

The Botpress server is set as production mode. Is this causing all settings to be cached in the PosgreSQL database maybe, so the JSON files are never (re)read? If so, how does one make changes to the config? I mean under version control in the Botpress web admin console you can copy the command to refresh changes TO the local file system. But what if you want to do it the other way, i.e. apply changes you made to JSON config files?

Furthermore:

  • I stop the botpress server
  • I make changes to my Botpress\data\global\botpress.config.json file and edit certain modules to be active (set the active flag to ture in the JSOn file) and then I run the bp.exe
  • the modules I just activated show as active
  • I then go to version control and copy the “bp.exe pull” command and run it
  • Lo and behold, the botpress.config.json file goes back to it’s prior state, i.e. the modules that I just activated and that DID become active are configured as inactive again.

It is as if the config settings were stored elsewhere, and it were impossible to override config settings by making changes to the JSON files. But how, then, should I change config settings that do not show up on the admin console, i.e. do need to be edited at the JSOn level?

The issue described above was caused by another instance of Botpress already running in the background. I set up a scheduled task in Windows to start the Botpress server upon bootup - which it did. Then, I ran another instance of the Botpress server via my server console from the command line. However, the original instance running in the background retained the old settings, so whenever I pulled an update from the Botpress server it would give me the old, retained values, essentially resetting my changes in the JSON files.

I stopped the background instance of the Botpress server, havign only the single instance from the command line running. In this case if I made changes to my JSON files and restarted the Botpress server from the command line thn the new settigns would be applied correctly, and the Bot Info Page would become visible in the webchat channel. (This was my original issue on this thread.)

So although I did not mange to figure out how to update settings on Heroku, I did manage to successfully install Botpress on my Windows server and did manage to display the Bot Info Page.

Thanks to @ abhisheksimon for your help!

1 Like

I’m glad you figured this out!

We published a new update in the last couple of days that will help you if you stumble on something similar in the future. You can now pull changes from a remote botpress server and push changes from your local instance to a remote botpress server without having redeploy changes or having to play around with the code editor. See it im the docs here.

1 Like

Thanks!

And this pull-push is quite a sleek solution! Independent of the hosting environment and other factors! An amazing idea and also well implemented - works like a charm! :slight_smile: Also great to use the in-admin code editor. Just makes it all so much easier! :+1:

1 Like